LED Lights

LED Lights

My tail light bulbs kept going in and out. Turned out to be a grounding issue at the tail light socket. So I figured while I am fixing that I might as well go LED. Below is what I did (click on any pic to make it larger)

 

 
Well the first thing you need are two of these. https://easyperformance.com/products/universal-flasher-module?_pos=1&_sid=40e3e56f6&_ss=r they will let the LED flash. The regular flasher in the Maverick use the current from the bulb to heat up a plate that expands and contracts to make the lights blink. Thats the clicking you hear. You will need two, one for the emergency flashers and one for the turn signal.

 

   
The first one is easy to find. Its bottom right drivers dash. The second, not so much. I was already taking my cluster out because those lights dont work either. If you dont take the cluster out, it is above the parking break. Just on the lip of the bottom of the cluster "shelf" by a big black cable that runs across it.

 

 

You then need to find which wire is positive. The other wire is the load wire.

 


You then connect the wires to the power and load. Then ground the black wire. This was just a temp ground here. I made it perm later. Note the metal tab with a hole is just for mounting. Has no electrical connection.

 


I then put them in the same spot under the dash. Wire tied them to the existing cable harness. Grounded them to an existing ground screw under the dash.

 

 That is it for the flashers. Now on to the trunk.

 


First thing I did was install a grounding bus bar.

 

 
     
I got some 3 wire plastic 1157 sockets. https://www.amazon.com/gp/product/B00LGKE4XM/ref=ppx_yo_dt_b_asin_title_o00_s01?ie=UTF8&psc=1 I will say these ones kinda suck. The tabs on them are very small and its a PITA to get them twisted to stay tight against the housing. You can also see the mess I was left to start with. Those blue clips are for a trailer plug. Whatever.....

 


Previously I had removed the white backup part of the tail light lens and replaced it with red. For this reason I had to T the two bulbs in the lens together so that they both acted like break/turn/tail lights. I soldered and shrink wrapped wires to both sockets, then to the original wire that ran the old socket.  For example, one green wire comes from each socket , then both tie into the original wire. I did not cut off the backup light socket, just in case I want to use it in the future.

 

      
I then cleaned up and tied up both sides. You can see the 4 black ground wires coming off the bus bar to each socket. Probably over  kill but I had the wire. I also removed the vampire plugs and the trailer plug and taped up the wound.

 

 
here is the left one done in full sun light. Yes the right one is original and actually on too.

 


Here they are both done. They look yellow in the pic, but they are very red. The LEDs themselves are red too.


 
Here are the turn signals in action

 

I also replaced both back side marker light. Both front under the bumper running / turn signal lights. The only ones I did not do were front side marker lights. I read those need  special box because they are actually the ground for each side lights. I need to do some testing on this and get those led too. I also replaced the license plate light and have an LED on order for the dome light. I want to do the instrument cluster lights in LED also.

 Click here for all the pics